Aller au contenu


Photo
- - - - -

Logiciel de gestion de collection - OT2


  • Veuillez vous connecter pour répondre
215 réponses à ce sujet

#41 Khazaar

Khazaar

    Hamster psychopathe

  • Membres
  • 4 127 messages
  • Sexe :Homme
  • Ville :Spy
  • Zone USDA :8a
  • Formation :Bonsaï Club Carolorégien (BCC)
  • Pays :Belgique
  • Département :Namur

Posté 09 mars 2006 - 11:14

Euh, concernant la date d'achat, comment fait-on, car moi elle est restée bloquée à 99 et impossible à débloquer. Ca vous est arrivé ou pas ?


Oui, c'est un bug déjà signalé, mais indépendant de lanig.

Pour le problème des années, c'est un problème connu de Trolltech qui n'apparait que sur certaines configurations de langues (dont le français) et ils ont décidé d'attendre QT 4.2 pour le résoudre. Comme on en est à QT4.1.1, il va falloir un peu de patience.


B.O.U.R.G.E.O.N. de l'A.R.B.R.E.
Brigade anti-citations sauvages
"Un ami, c'est quelqu'un qui vous connaît bien et qui vous aime quand même."
La charte PB - Le mode d'emploi de PB

#42 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 09 mars 2006 - 21:42

Je vient de réessayer. Effectivement j'ai le message mais c'est une fois que je clic sur ok que ca plante.
Mais vraiment y'a rien d'urgent.

C'est pas le problème d'être urgent ou pas, c'est que cela ne devrait pas planter et que cela plante :newsm_14: . J'ai relu le code et je vois pas de cause évidente. Sous Win98, je n'arrive pas à le faire. Quelle version de windows utilises tu ? Peux-tu m'envoyer en mp ton fichier .otq ?

Merci
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#43 petit-arbre

petit-arbre

    ^-^

  • Modérateurs
  • 5 862 messages
  • Sexe :Homme
  • Ville :Sarthe
  • Zone USDA :8b
  • Formation :Ecole de Bonsai Maillot-Murakawa
  • Pays :France
  • Département :72

Posté 09 mars 2006 - 21:51

Je viens de le reproduire avec XP !

je voulais mettre la date d'achat = 99 et comme je ne voulais pas cliquer 15000 fois sur la fleche du bas j'ai essayé d'ecrire 99 ça n'a pas fonctionné.

j'ai cliqué sur la fleche du bas et là 99 est apparu et plus moyen de changer la date ni de valider la nouvelle fiche de l'arbre

OT.jpg

#44 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 09 mars 2006 - 22:04

Oui, c'est un bug déjà signalé, mais indépendant de lanig.

Pour Khazaar:
Merci d'avoir répondu. Il faut donc taper les années à la main.

Je suis embêté avec ce bug de Trolltech parce que n'importe quel utilisateur va le rencontrer.
J'ai bien trouvé des solutions, mais je les trouve pires que la situation actuelle.

Je peux les proposer, à voir ce qui est préféré.

-->affichage 09032006 Les flèches sont opérantes sur le jour, le mois et l'année mais je trouve cela peu lisible.
-->affichage 09 Mar 2006, comme actuellement mais par un autre moyen, les flèches sont actives sur les jours et l'année, mais plus sur le mois.

Perso, je trouve plus gonflant de taper le mois en lettres à la main, que les années, mais je peux changer si cela est souhaité.

Pour Petit-Arbre :
Je n'ai pas de problème pour reproduire le bug des années, il est présent même sous Linux. C'est le bug signalé par Gailuron que j'aimerais résoudre.
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#45 petit-arbre

petit-arbre

    ^-^

  • Modérateurs
  • 5 862 messages
  • Sexe :Homme
  • Ville :Sarthe
  • Zone USDA :8b
  • Formation :Ecole de Bonsai Maillot-Murakawa
  • Pays :France
  • Département :72

Posté 09 mars 2006 - 22:07

Je n'arrive pas à mettre une date autre que 06 ou 99 ???

lorsque je clique sur la fleche haute ou basse je passe de 06 à 99.

Et pourquoi pas un champ à remplir

le mieux est l'ennemi du bien !

bon courage

#46 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 09 mars 2006 - 22:31

Je n'arrive pas à mettre une date autre que 06 ou 99 ???

Nos réponses se sont croisées.
En fait le bug sous windows ne se révèle pas comme sous linux et est beaucoup plus grave. Sous linux, je peux taper la date à la main (c'est ce qui m'a poussé à laisser la situation en l'état) mais en effet sous win ce n'est pas possible et cela empêche vraiment l'utilisation du bidule. Je vais donc rectifier cela....et faire chauffer le rapport de bug chez Trolltech (la description n'était pas aussi sévère...)

(edit)
Bon en fait, je viens d'essayer sous linux et le format
09-03-2006 me paraît assez lisible et utilisable. Je vérifie que c'est bon aussi sous win et je mets en ligne ce W.E. un correctif pour la beta3 parce que cela rend le programme vraiment inutilisable. Par contre, pour une beta4, j'aimerais résoudre le bug signalé par Gailuron (j'ai trouvé d'autres trucs à régler).
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#47 petit-arbre

petit-arbre

    ^-^

  • Modérateurs
  • 5 862 messages
  • Sexe :Homme
  • Ville :Sarthe
  • Zone USDA :8b
  • Formation :Ecole de Bonsai Maillot-Murakawa
  • Pays :France
  • Département :72

Posté 09 mars 2006 - 22:43

oups messages croisés et pas bien compris !

sinon moi j'ai essayé d'ajouter une espèce et ça marche !
désolé

#48 Gailuron

Gailuron
  • Membres
  • 11 messages
  • Pays :France
  • Département :49

Posté 10 mars 2006 - 18:40

salut

Alors j'utilise Win xp pro sp2.
Par contre pour le fichier, j'ai pas trouver dans les MP l'option des pièces jointes.
Donne moi un mail si tu veut.

#49 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 11 mars 2006 - 08:24

J'ai mis en ligne une mise à jour qui normalement corrige le problème des dates. Il est donc fortement conseillé de la télécharger pour avoir un programme utile.

Deux possibilités pour le téléchargement :

-télécharger le fichier ot2-win-beta3_1.zip et le décompresser ou
-télécharger le fichier ot2.zip, le décompresser pour avoir ot2.exe et l'utiliser pour remplacer le fichier ot2.exe du téléchargement précédent.

Adresse du téléchargement.
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#50 Khazaar

Khazaar

    Hamster psychopathe

  • Membres
  • 4 127 messages
  • Sexe :Homme
  • Ville :Spy
  • Zone USDA :8a
  • Formation :Bonsaï Club Carolorégien (BCC)
  • Pays :Belgique
  • Département :Namur

Posté 11 mars 2006 - 10:59

Merci bcp laniq ! Ca va me permettre de tester le programme plus en profondeur. Super boulot en tous cas ! :newsm_12:
B.O.U.R.G.E.O.N. de l'A.R.B.R.E.
Brigade anti-citations sauvages
"Un ami, c'est quelqu'un qui vous connaît bien et qui vous aime quand même."
La charte PB - Le mode d'emploi de PB

#51 02conduite

02conduite
  • Membres
  • 30 messages
  • Sexe :Homme
  • Ville :Grignols
  • Zone USDA :8a
  • Pays :france
  • Département :Dordogne

Posté 11 mars 2006 - 18:17

le lien pour telecharger la mise a jour ne marche pas :o(
une personne pourait m'envoyer le nouveau fichier ot2.exe ?
mais a par ça super boulot lanig

#52 jps

jps

    ATTENTION .Ceci n'est pas une PUB !

  • Membres
  • 2 922 messages
  • Sexe :Homme
  • Ville :LYON
  • Zone USDA :8a
  • Formation :Bonsaï Club du Lyonnais.
  • Pays :france
  • Département :69

Posté 11 mars 2006 - 18:51

le lien pour telecharger la mise a jour ne marche pas :o(


Attends que le serveur marche! :rolleyes:

:newsm_15: We're Sorry.
The SourceForge.net Website is currently down for maintenance.
We will be back shortly

Bravo Laniq :newsm_12:
Jean-Pierre
Nettoyeur de quotes inutiles !

L'INSERTION DES PHOTOS C'EST LA

La charte PB -/-PB Mode d'emploi-/-Les citations



A.R.B.R.E à pain
Bien faire et laisser braire......

#53 02conduite

02conduite
  • Membres
  • 30 messages
  • Sexe :Homme
  • Ville :Grignols
  • Zone USDA :8a
  • Pays :france
  • Département :Dordogne

Posté 11 mars 2006 - 19:45

ça y est je l ai :newsm_6:

#54 eprom

eprom
  • Membres
  • 17 messages
  • Ville :Yonne
  • Zone USDA :8a
  • Formation :S.H. de Sens - Section Bonsaï
  • Pays :France
  • Département :89

Posté 11 mars 2006 - 19:56

Bonsoir,
Après téléchargement et installation de la nouvelle version beta 3_1, le bug sur les dates est effectivement corrigé, en revanche je plante quasi systématiquement lors de l'ajout d'une photo avec le message suivant :

plantage_photo.jpg


Je tourne sous win xp pro sp2.
Toutefois, après relance du programme, l'ajout de la photo est fait et le fichier disparait du dossier arrivage et est bien transférer dans les dossiers images, originaux et vignettes. Ce n'est donc pas bloquant, juste genant si on a beaucoup de photo à ajouter.
En tout cas c'est déjà un gros boulot. Bravo :newsm_12:
Cordialement
La différence entre la théorie et la pratique est toujours plus grande en pratique qu'en théorie.

#55 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 11 mars 2006 - 21:05

Je viens d'essayer de rajouter des photos sous windows XP pro sp2 aussi et je n'ai pas eu de plantage.
J'aurais donc besoin de la méthode détaillée, depuis le lancement du programme, click par click par click etc. pour reproduire le plantage.
En particulier, j'ai remarqué que le dialogue accepte, alors qu'il ne le devrait pas, l'absence de certains choix dans les menus déroulants. Est-ce possible de lier le plantage à certaines de ces valeurs ?

Si d'autres personnes peuvent confirmer le bug, cela m'aiderait aussi, merci.
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#56 eprom

eprom
  • Membres
  • 17 messages
  • Ville :Yonne
  • Zone USDA :8a
  • Formation :S.H. de Sens - Section Bonsaï
  • Pays :France
  • Département :89

Posté 11 mars 2006 - 21:25

Je viens d'essayer de rajouter des photos sous windows XP pro sp2 aussi et je n'ai pas eu de plantage.
J'aurais donc besoin de la méthode détaillée, depuis le lancement du programme, click par click par click etc. pour reproduire le plantage.
En particulier, j'ai remarqué que le dialogue accepte, alors qu'il ne le devrait pas, l'absence de certains choix dans les menus déroulants. Est-ce possible de lier le plantage à certaines de ces valeurs ?

Si d'autres personnes peuvent confirmer le bug, cela m'aiderait aussi, merci.


Voila ce que je fais :

Je lance OT2, Dans l'onglet arbres, click droit, ajouter une photo. Dans la fenetre "ajouter une photo", bouton choisir (je prends mon fichier en jpg de 1536*2048 d'environ 1Mo), je rajoutes le titre (01 mai 2005), je changes la date (01-05-2005) et je click sur accepter et après environ 7-8 secondes

plantage_01.jpg

:(

Mes applications actives sont IE 6 (forum parlons bonsai), outlook express et un explorateur windows.
Ma conf : amd 2400+ avec 768 de RAM.

Si tu as besoin d'autres précisions, n'hésite pas
La différence entre la théorie et la pratique est toujours plus grande en pratique qu'en théorie.

#57 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 11 mars 2006 - 21:56

OK, merci.
J'ai trouvé où est le bug (du code que j'ai rajouté récemment) et je suis en train de réfléchir à la solution.
En attendant, tu peux rajouter des photos sans planter en les ajoutant par l'onglet "photos" et en choisissant le type "arbre" et ensuite dans le menu déroulant "référence", ton arbre.
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.

#58 eprom

eprom
  • Membres
  • 17 messages
  • Ville :Yonne
  • Zone USDA :8a
  • Formation :S.H. de Sens - Section Bonsaï
  • Pays :France
  • Département :89

Posté 12 mars 2006 - 11:44

OK, merci.
J'ai trouvé où est le bug (du code que j'ai rajouté récemment) et je suis en train de réfléchir à la solution.
En attendant, tu peux rajouter des photos sans planter en les ajoutant par l'onglet "photos" et en choisissant le type "arbre" et ensuite dans le menu déroulant "référence", ton arbre.



Merci.

:newsm_15:

Bon courage
La différence entre la théorie et la pratique est toujours plus grande en pratique qu'en théorie.

#59 petit-arbre

petit-arbre

    ^-^

  • Modérateurs
  • 5 862 messages
  • Sexe :Homme
  • Ville :Sarthe
  • Zone USDA :8b
  • Formation :Ecole de Bonsai Maillot-Murakawa
  • Pays :France
  • Département :72

Posté 19 mars 2006 - 16:08

Salut lanig !

je viens te reporter un bug :

lorsque tu démares le programme tu as tous les arbres qui s'affiche si tu demande l'affichage des kusamonon (il n'y en a pas encore de saisi dans ma base) rien ne s'affiche ce qui est normal.
Puis je reviens sur tous les arbres et là plus rien !
la liste est vide quelque soit le choix d'affichage !

C'est un peu le même problème lorsque tu es sur les photos.
J'ai mis deux photos de pot et une photo d'arbre, je passe facilement de l'un à l'autre mais je ne peux plus afficher les deux catégories en même en choisissant "toutes les photos". De plus, les deux pots s'affiche bien la première fois puis en changeant d'affichage je ne retrouve plus qu'un seul pot !


J'ajoute que ça se reproduit sur toutes les sortes de liste d'affichage !
a plus

#60 lanig

lanig
  • Membres
  • 3 670 messages
  • Zone USDA :8b
  • Pays :France
  • Département :35

Posté 19 mars 2006 - 19:39

Merci de ton message.
C'est une "feature" qui a tourné en bug. :newsm_4:
En attendant la prochaine version, il faut juste remettre manuellement la valeur du champ "montrer" à plus de zéro et c'est bon.

En passant, les bugs que m'a signalé Gailuron sont assez pénibles (ils me demandent une réécriture du dialogue) alors que la saison des rempotages ayant commencé, je n'ai plus beaucoup de temps.
OT2 Logiciel libre pour la gestion de votre collection de bonsai. La version 1.1 est sortie.


0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)